Kde, Kubuntu, PPA

KDevelop 4 rc1 + plugins – Kubuntu Karmic

Kdevelop 4 and kdevplatform rc1 .deb packages for Kubuntu Karmic 9.10 (with kde 4.4.2 from ppa:kubuntu-ppa/backports) are available on my kdevelop PPA.

Kdevelop rc1 about dialog
Kdevelop rc1 about dialog

You can add my kdevelop PPA running:

sudo add-apt-repository ppa:daniele.domenichelli/kdevelop
sudo apt-get update

Then to install kdevelop, just run

sudo apt-get install kdevelop

or if you installed beta9 packages from my PPA, just run

sudo apt-get update
sudo apt-get upgrade

As usual, on the same ppa you’ll find some kdevelop plugins:

Official release candidates:

kdevelop-plugin-php (rc1)
kdevelop-plugin-php-docs (rc1)

Official betas + patches from svn:

kdevelop-plugin-executebrowser (beta1+svn)
kdevelop-plugin-executescript (beta1+svn)
kdevelop-plugin-xdebug (beta1+svn)

From KDE Playgroud (warning: Source is taken from svn and it’s not supposed to be released yet, so it might not work or might break kdevelop install, so use them only if you know what you are doing…)

kdevelop-plugin-extragear-upload
kdevelop-plugin-playground-bazaar (not building at the moment)
kdevelop-plugin-playground-controlflowgraph
kdevelop-plugin-playground-coverage
kdevelop-plugin-playground-css
kdevelop-plugin-playground-gettersetter
kdevelop-plugin-playground-git
kdevelop-plugin-playground-mercurial
kdevelop-plugin-playground-qtdesigner
kdevelop-plugin-playground-valgrind
kdevplatformveritas

Please report me any bug in plugin packaging (missing dependencies, etc.) but report to the kdevelop developers bugs related to the plugin itself.

Kde, Kubuntu, PPA

Cantor + R Backend – Kubuntu Karmic

“Cantor is an application that lets you use your favorite mathematical applications from within a nice KDE-integrated worksheet interface. It offers assistant dialogs for common tasks and allows sharing of worksheets with others. Available backends are Sage, Maxima, R, and KAlgebra.”

Sadly R backend is not supported in kubuntu (see here) because r-base package is in universe and therefore kde-edu package cannot depend on it.

Anyway, if you need R support, you probably already enabled universe repository, and you can find on my PPA with R backend.

To install it just add my PPA to your software sources (you also need kubuntu-ppa/backports repository enabled) and upgrade

sudo add-apt-repository ppa:daniele.domenichelli/ppa
sudo apt-get update
sudo apt-get upgrade